Palladio.TX

Aus SDQ-Wiki
Zur Navigation springen Zur Suche springen
Palladio Addon (Liste)
Name Palladio.TX
Contacts Philipp Merkle (http://sdq.ipd.kit.edu/people/philipp merkle/)
State Incubation
Is Stand-alone Analysis? no
Extends Analyses
Extends Metamodels
Code Location https://svnserver.informatik.kit.edu/i43/svn/code/Palladio/Addons/Palladio.TX/
Update Site https://sdqweb.ipd.kit.edu/eclipse/palladio/addons/palladiotx/nightly/
JIRA TBD

Short Summary

Palladio extension for modelling and analysis of transactional information systems.

Documentation

Installation Instructions

General Installation Instructions

  1. Follow steps 1 through 5 from EventSim Installation Instructions
  2. Check out Palladio.TX sources into workspace
    1. Download Palladio.TX team project set from https://svnserver.informatik.kit.edu/i43/svn/code/Palladio/Addons/Palladio.TX/trunk/palladiotx.psf (use your own or anonymous credentials)
    2. Choose File -> Import -> Team -> Team Project Set
    3. Select File and browse for downloaded palladiotx.psf file
  3. Install PCM.TX into Eclipse
    1. Choose File -> Export -> Plug-in Development -> Deployable plug-ins and fragments
    2. Select all plug-ins starting with org.palladiosimulator.pcmtx
    3. Select Install into host. Finish.

Additional Installation Instructions for Developers

  1. Check out PCM metamodel sources into workspace from https://svnserver.informatik.kit.edu/i43/svn/code/Palladio/Core/trunk/PCM/org.palladiosimulator.pcm
  2. Install EcoreTools into Eclipse (not necessary if you installed Eclipse Modeling Edition)
    1. Go to Help -> Install New Software... and "work with" http://download.eclipse.org/ecoretools/updates/releases/3.0.1/mars
    2. Select and install all features listed
  3. Install EMF Profiles into Eclipse: this enables diagram support for .emfprofile_diagram files
    1. Go to Help -> Install New Software... and "work with" http://www.modelversioning.org/emf-profiles-updatesite/
    2. When working with .emfprofile_diagram files, definitely makes sure to know of a serious bug described under https://groups.google.com/forum/#!msg/emf-profiles/_kp_7S8yKJ8/RAUXE89b0sYJ, where also a sufficient workaround is presented

PCM.TX Modelling Guide

PCM.TX currently provides only EMF-based tree editors for creating models.

Creating a Palladio Project

First create a Palladio project. We use the Palladio Minimal Example throughout this guide.

  1. Choose File -> New -> Other... -> Palladio Modeling -> New Palladio Project
  2. Choose a project name and press Next
  3. Choose Minimum Example Template. Finish.

Creating Entity Types

  1. Create the repository for entity types
    1. Having selected your project, choose File -> New -> Other..., search for resourcetype and select Resourcetype model. Next.
    2. Choose a file name. Next.
    3. Select Resource Repository as Model Object. Finish.
  2. Add an entity type to the repository
    1. Open the repository created in the previous step. A tree editor should have opened.
    2. Right click on the Resource Repository node, choose New Child -> Add EntityType (...)
    3. (If there is no Properties view opened in Eclipse, right click in the editor and choose Show Properties View)
    4. Click on the created entity type and change its name to Person via the Properties view.
  3. Add a resource interface for an entity type. By convention, each entity type needs to provide exactly one resource interface.
    1. Right click on the Resource Repository node, choose New Child -> Add ResourceInterface (...)
    2. Click on the created resource interface and change its name to IPerson via Properties view.
  4. Add resource signature to the interface
    1. Right click on the IPerson node, choose New Child -> Add ResourceSignature (...)
    2. Change the signature's name to Read
  5. Repeat the previous step, but name the signature Write this time. Increment the resource service id.
  6. Let the entity type provide its resource interface
    1. Right click on the Person node, choose New Child -> Add ResourceProvidedRole (...)
    2. Change the role's name to PersonProvidedRole
    3. Set the role's provided interface to IPerson via Properties view.

The result should look as follows.

Pcm.tx-entity-example.PNG

Mapping Entity Types to Tables

  1. Create the data repository
    1. Having selected your project, choose File -> New -> Other..., search for pcmtx and select Pcmtx model. Next.
    2. Choose a file name. Next.
    3. Select Data Repository as Model Object. Finish.
  2. Open the repository created in the previous step. A tree editor should have opened.
  3. Load the entity types repository created above
    1. Right click somewhere in the tree editor. Choose Load Resource....
    2. Browse Workspace... and select the resourcetype file created above
  4. Right click on the Data Repository node, choose New Child -> Add Table
  5. (If there is no Properties view opened in Eclipse, right click in the editor and choose Show Properties View)
  6. Click on the created table and set the following properties via the Properties view.
    1. Set name to Person
    2. Set rows to 100
    3. Set entity types by clicking the value cell in the types row
      1. Click the [...] button that appeared
      2. Use Add and Remove buttons to select entity types mapped to this table

So far the created data respository model is not yet valid because the table's Database attribute is mandatory. Continue with the next step.

Combining Tables to Databases

  1. Open the data repository created above. A tree editor should have opened.
  2. Right click on the Data Repository node, choose New Child -> Add Database
  3. (If there is no Properties view opened in Eclipse, right click in the editor and choose Show Properties View)
  4. Click on the created database and set a name via the Properties view.
  5. Assign tables to this database by changing a table's database property